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The Migrate tool is not uploading msg files into Content Server

Problem

You are using the Migrate tool in COG to send email files (msg) to Content Server but see the following error:

Command Line:

CODE
100.00% Total Documents Migrated : 0. Total Data Migrated : 0                                                                                                                                                                      00:00:14Program exited with error code 1. The log may contain more details.

Log file

CODE
[15:21:44 INF] Starting Program - Migrate --destination-source-settings C:\CLI ToolKit\query.json --start-location 73884 -q C:\Users\jsmith\Documents\COG Batch Files\settings.json -u http://localhost:9200 -i jsmith-fqdn
[15:21:44 INF] Version 2.6.0.0.48  (16cbdbeb529533b914298f189e1c60fad0528786 )
[15:21:44 INF] Running As DOMAIN\username
[15:21:49 ERR] Unable to migrate item 009763f1d4954ac8e361933e12e649ebf7b7cbb1. Content Server errored trying to create a node in '123456'. Call failed with status code 500 (Internal server error): POST http://10.1.1.1/otcs/cs.exe/api/v1/shinynodes.
[15:21:49 ERR] Unable to migrate item 028264c16aa835537f830e7ca56bebed1d625998. Content Server errored trying to create a node in '123456'. Call failed with status code 500 (Internal server error): POST http://10.1.1.1/otcs/cs.exe/api/v1/shinynodes.

Cause

No upload folder is specified in the OTCS Admin settings or the folder does not have permissions.

Solution

Starting with Content Server 21.4, the upload directory must be set in the System Variables (func=admin.sysvars) for this feature to work. The location of the upload directory does not need to be in the main opentext install folder but will require the same permissions.

In cases where there are multiple OTCS nodes, the upload directory must be defined on EACH node that is being used to migrate emails.

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