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HTTP 503 Service Unavailable

This article applies to Shinydrive Server 2.4.2.0 and later.

Possible Causes

  1. Using the Shinydrive feature “Go Offline When Content Server Cannot Be Reached” with Content Server deployed via IIS
    Tomcat (and therefor Shinydrive Server) is running as a local machine account and not as an authenticated IIS user. Shinydrive server has a check built-in to see if Content Server is alive, however, if IIS is locked down to not allow Anonymous Authentication, that call comes back in a way the server was not expecting. This will trigger Shinydrive Server to make that content source (Content Server) offline, causing a 503 error and authentication will error

  2. Shinydrive Server does not receive 2xx or 3xx response
    If for any reason Shinydrive Server does not receive a 2xx or 3xx HTTP response from Content Server when attempting to connect or authenticate. These responses can be viewed in the Tomcat logs.

Solutions

Using the Shinydrive feature “Go Offline When Content Server Cannot Be Reached” with Content Server deployed via IIS

In order for Shinydrive to check Content Server’s availability, you will need to run the Tomcat 8.5 or higher Windows service as an IIS authorized service/user account. This can be achieved via Windows Services (Run Dialog > “services.msc“)

  1. Right-click on the service associated with the Tomcat instance running Shinydrive Server

  2. Click Properties

  3. Click the Log On tab

  4. Click the radial button beside “This account

  5. Either enter the account name (domain\user) or use the Browse button to find the account

  6. Enter the password for the account and enter it again in the confirmation box

  7. Click OK

  8. In some circumstances, you may need to authenticate as an admin to perform this action or launch services.msc as an administrator

Shinydrive Server does not receive 2xx or 3xx response

503 errors, like many errors, can be caused by a variety of issues. Logs from both Tomcat and Content Server can offer guidance to where this error is occurring on the network.

If you have already confirmed this has not been caused by IIS authentication issues around the Go Offline When Content Server Cannot Be Reached feature, and you are using SSL (HTTPS) for your Content Server and/or OTDS, you may be hitting an SSL cert error in the chain. You will need to ensure that the SSL certificates have been configured in Tomcat as well as imported into that server’s (the server running Tomcat) Java Keystore.

You can find out more information on how to import your SSL certificate into Java from Oracle: https://blogs.oracle.com/jtc/installing-trusted-certificates-into-a-java-keystore

You can find out more information on how to configure Tomcat with your SSL cert from our article Shinydrive & SSL

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