Unable to connect to the remote server
This article applies to the Shinydrive Windows Client.
Problem
The Shinydrive client fails to connect after Domain Support is Enabled for Content Server. All users get an "Unable to connect to the remote server" error.
Cause
Content Server Web Services no longer map the root node "EnterpriseWS" properly after domains have been enabled. Since the "EnterpriseWS" alias is typically what is found in the Shinydrive cs-rest.properties file, this will need to be changed to an actual Content Server Node ID in order for it to work.
Solution
For anyone using domains like this, we recommend not using the EnterpriseWS alias, instead treat it like any other folder and use its Node ID. Update your cs-rest.properties file like the following:
DRIVE0_ROOTID=2000
DRIVE0_ROOTTYPE=Folder
That should map to the default EWS for any new install. Older upgraded installs may have a different node id for their EWS volume object.